
 

  Page 1 of 9 

 
 

Derivation of 
Digital Surface Models and Digital Terrain Models 

from Airborne Laser Scanning Data 
 

 
 
 

 
 
 

Institute of Photogrammetry and Remote Sensing 
Vienna University of Technology 

 
 
 
 

1. Theoretical Background   .................................................................................. 2
Filtering of Laser Scanner Data   .......................................................................... 2
Hierarchical Approach   ........................................................................................ 4

2. Instructions for DTM derivation and visualisation with SCOP++   ...................... 6
New project   ........................................................................................................ 6
Open an existing project   ..................................................................................... 6
Add a Model overlay (This dialog opens automatically after creating a new 
project)   ............................................................................................................... 6
Data import (This dialog opens automatically after creating a new overlay)   ........ 6
Limits   ................................................................................................................. 6
Hierarchic robust interpolation   ............................................................................ 6

Filter Step X…   ................................................................................................ 7
Weight function   ............................................................................................... 7
Interpolation   .................................................................................................... 7
Interpolate Step X…   ....................................................................................... 8
SortOut Step X…   ............................................................................................ 8
Edit Step X...   ................................................................................................... 8

Difference model   ................................................................................................ 8
3. Handling of error messages and program crashes  .......................................... 9
4. Further Information   ......................................................................................... 9

 



ADDRESSS training course, 19-28 August 2010,  
Balaton Limnological Research Institute, Hungary 
 

Page 2 of  9 

1. Theoretical Background 
 
This section will give an overview on the special methods for DTM computation from 
laser scanner data. It will present the theoretical aspects in compact form. More de-
tailed information is available in the SCOP++ manual and references to it will be 
given in the text.  

Filtering of Laser Scanner Data 
The principles of the classification of laser scanner data are very simple. The first 
step is to compute an averaging surface which runs in a medium layer between ter-
rain and off-terrain points. The terrain points will generally lie below this intermediate 
surface and the off-terrain points above it. For a profile this is shown in the next fig-
ure.  
 

 
 
The gray line is the trend which is split off before the computation. In the next figure a 
histogram of the residuals is shown. For positive values the point lies above the sur-
face.  
 

 
 
Now, the key idea is the following: Compute weights, individual for each point, de-
pending on the signed distance from the point to the surface. If the distance is posi-
tive, the weight shall be low (close to zero), if the distance is negative, the weight 
shall be high (close to one). The images show the weight function overlayed to the 
residuals and the weights over the profile ground plan positions.  
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Then repeat the terrain computation under consideration of the weights. Points with 
high weight will attract the surface while points with low weight will have only little in-
fluence on the run of the surface.  
 

 
 
The gray line is the surface from the first iteration where all points had the same 
weight. The black line is the resulting surface after a few iterations.  
 
Remarks  
This method works well for wooded areas, even if the penetration rate is about 50% 
or below. In such a case the off terrain points are vegetation points, and the number 
of required iterations is three or four. In the first iterations the canopy points are elim-
inated, in the next iterations the under story points are found.  
The method fails if the points are not mixed thoroughly. This means that the vegeta-
tion points must not appear in clusters without one terrain point. Especially if the me-
thod is applied to city areas, the off-terrain points show this systematic behavior (e.g. 
at house roofs).  
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Hierarchical Approach 
For the above reasons, and also in order to make the computation more robust, a 
hierarchical approach is applied. For this, the original data is thinned out and the fil-
tering is performed at different levels of resolution, starting with the coarsest level.  
First, the data set with the lowest resolution is generated by a thin out of the original-
ly given points. In this thin out step different methods can be applied. In SCOP++ a 
raster based thinning is provided which works by laying a grid over the complete do-
main and determining one point for each cell. This point can be computed in different 
ways e.g. taking the lowest or the mean point in each cell. Schematically this is 
shown in the figure showing a profile.  
 

 
 
The red points are the selected points for each cell. The vertical bars denote the grid 
width.  
In the next step the Robust Filtering - as explained above - is applied. This gene-
rates a coarse terrain model.  
 

 
 
The red surface is obtained with equal weights for all points and the black surface is 
determined after a few iterations. It is a rough approximation of the terrain surface.  
In the third step the original points are compared to this coarse DTM, the aim of this 
step is to sort out the original points which are close to the coarse surface. These 
points provide a finer description of the terrain than on the previous level. It is shown 
in the following figure.  
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A tolerance band is laid around the coarse surface. The green points are selected. 
As it can be seen, not only the terrain points are chosen, but also points on the low 
vegetation.  
The three steps from above (thin out - filter - sort out) are repeated. The first thin 
out operated on the original points, but for further runs of thin out the points from the 
previous sort out are thinned out. After the last sort out only another filter is applied 
and the final terrain model is obtained from the classified terrain points in the original 
resolution.  
In our example no intermediate (thin out - filter - sort out `triples') are necessary 
and the points are filtered robustly. The result is shown in the figure.  
 

 
 
The red line shows the surface with equal weights for all points. After the robust in-
terpolation the black surface i.e. the final terrain model, is obtained. 
 
Remarks  
This approach cannot only be used to filter (classify) laser scanner data, but also in 
order to eliminate grossly false points from other data sources, including terrestrial 
laser scanning and tacheometry.  
 
For airborne laser scanning data usually three levels are sufficient. Thus the se-
quence of steps is: ThinOut - Filter - SortOut - ThinOut - Filter - SortOut - Filter  
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2. Instructions for DTM derivation and visualisation with SCOP++ 

Start SCOP++ with the icon . 

New project 
Project ► New… ► Name enter project name, Location enter location for saving ► 
ok 
 
At the location for saving, a folder with the name of the project appears. It contains 
the files “project name.spr”, “project name.TOP”, and “project name.cmf”. 
 
Attention: The project name may exist only once on a computer! 
HINT: Leave the default directory in Location to ease the overview on the already 
used names. 

Open an existing project  
Project ► Open… ► Browse project name.spr ► ok 

Add a Model overlay (This dialog opens automatically after creating a new project) 

Overlays ► Add model overlay ► Name enter overlay name ► ● Both ► ok 
 
Model-only: Enables the visualisation (shading, height coding, isolines) of a 
DSM/DTM (*.dtm). 
Data-only: Enables to edit and visualise the data set (*.xyz, *.wnp, etc.). 
Both: Enables DSM/DTM derivation, visualisation of the data set and of the 
DSM/DTM, editing of the data set. 
 
A button with the overlay name appears on the left side of the window (from now on 
called ModelOverlay) 
 
In the project directory, a folder with the overlay name appears. The results of the 
DSM/DTM derivation are written into this folder. 

Data import (This dialog opens automatically after creating a new overlay) 

ModelOverlay ► Import/Export ► Data  ► Import…  ► Browse (set Filename 
and Data format) ► ok 

Limits 
Either the whole area or a smaller part can be considered for DSM/DTM derivation or 
visualisation. You can digitise the area of interest in Limits..., set coordinates with 
Limits... ► Edit or take the whole area with Limits... ► Set to max. The limits are 
valid for the checked options in Limits for (Screen, Model, Views, Data). 
 
Attention: Limits are always set for all overlays! 

Hierarchic robust interpolation 
ModelOverlay ► Model ► ● Robust filtering ► Details robust…  
 
Window DTM overlay name: Robust filter strategy: 
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Parameter persistence 
Select Robust filter strategy “Lidar DTM Default” instead of the default strategy Li-
dar Default*, then a sequence of steps appears in Steps (EliminateBuildings StepX, 
ThinOut Step X, Filter Step X, Interpolate Step X, SortOut Step X, Edit Step X). The 
sequence of these steps can be changed in Modify strategy (At position ● Insert 
step or ● Remove step; Position 0 to last; Add ●EliminateBuildings ● ThinOut, ● 
Filter, ● Interpolate, ● SortOut or ● Edit ●FillVoidAreas; Realize fulfills the 
change; Attention: a Filter or Interpolate step has to be set before a SortOut step, the 
whole sequence has to be terminated with an Interpolate or Filter step)  
 
The steps may be activated resp. deactivated and the parameters of these steps may 
be changed by pressing the respective button and selecting Properties... 
 
EliminateBuildings Step X... 
Morphological (shape-based) filter for the elimination of points on buildings. The filter 
is based on a grid of width Cell size. It detects connected cells as building areas, if 
the area is >= Minimal area, if the slopes between the suspected cells is low, and if 
the slopes to the bordering, presumably non-building cells is >= Minimal slope. 
 
ThinOut Step X... 
Thin out of the data: Take the Lowest, Highest, Mean, or Center point in each cell 
(Cell size). ALS data demand the Lowest point due to their height distribution. 
Result: stepX.tho 
 
Filter Step X… 
In this step the robust interpolation is applied. First, a DTM from the point cloud is 
computed without weights. Afterwards, the ALS data are weighted on the basis of 
their residuals. After some iterations, the terrain and off-terrain points are written off.  
The user may influence the weight function and the interpolations. 
 
Weight function 
Using ALS data low points get high weights (Lower branch no descent) because they 
most likely represent terrain points (exception: “long ranges”). 
Halfweight: Size of the residual which should be weighted with 0.5. 
Slant: Slant of the weight function, the smaller this value, the steeper the function.. 
 
Interpolation 
Trend: For every CU a tilted plane is computed. 
Prediction: Basis of the DTM derivation is the linear prediction. 
 
Number of Iterations: Maximum number of iterations. 
 
Model-points relative to preliminary surface:  
Here, you can set the origin of the weight function below, on, or above the prelimi-
nary surface. Using ALS data the origin of the weight function should lie below the 
preliminary surface. 
 
Penetration rate Estimation of the penetration rate, i.e. how many terrain points are 
existing (percentage)? Is used to define the origin of the weight function, as well. 
  
Details Interpolation... Vide linear prediction. The grid width has to be set within the 
window. 
Result: stepX.grd, stepX.veg, stepX.dtm 



ADDRESSS training course, 19-28 August 2010,  
Balaton Limnological Research Institute, Hungary 
 

Page 8 of  9 

 
Interpolate Step X… 
Vide linear prediction. The grid width has to be set within the window. This step is 
necessary after the robust interpolation to derive a DTM from the declared terrain 
points without robust weights. 
Result: stepX.dtm 
 
SortOut Step X… 
Specification of the tolerance band surrounding the earlier derived DTM. Below sur-
face/Above surface: set respectively the maximum allowed distance to the DTM or 
no limit).  
Result: stepX.sog, stepX.sov 
 
Edit Step X... 
The program GVE opens automatically, there is the possibility to edit the data.  
Attention: Save the resulting point cloud as stepX.edt and close the GVE, otherwise 
the DTM derivation is not continued. 
 
FillVoidAreas Step X... 
Large areas without data may result from the filtering of ALS data, which in turn may 
generate problems in the high resolution inerpolation. In order to avoid them, those 
areas may be filled with additional, estimated points using FillVoidAreas. In doing 
so, Sampling interval determines the minimum distance to the next original data 
point, above which a new point will be inserted. Additionally, this parameter specifies 
the distance among the filling points. Bridging distance defines the maximum dis-
tance to the next original point, above which no filling points will be generated. For 
the estimation of filling point heights, three methods are available: Linear prediction, 
Moving planes, and Triangulation. The first two start with a temporary thinning of 
the original data.  Subsequently, the filling point heights are interpolated at a low res-
olution. 
 
Attention: To get a calculation protocol check in Options ► Protocol (you can find 
the protocol in ModelOverlay ► Model ► Protocol after sDTM computation) 
 
In order to analyse the results of intermediate processing steps the individual steps 
can be de-activated by clicking on the respective step. It is useful to never de-
activate the last Interpolate step. In order to check the accepted points of a certain 
SortOut Step just deactivate all steps after the respective SortOut step and just acti-
vate the last Interpolation step. For the final DTM a FillVoidAreas should be used 
in order to close data holes. 

Difference model 
Requirement: DSMs/DTMs do exist already in two overlapping ModelOverlays (ex-
cept you want to add or subtract a horizontal plane). 
 
Tools ► Difference models...  
 
Window Difference models  
 
Remove the check mark from Use constant plane; choose a ModelOverlay respec-
tively for Second overlay and First overlay (Second overlay minus First overlay); 
set file name and path in Save as; set check mark at Add in Add as model overlay, 
set a new overlay name for the difference model 
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Further information can be found in the SCOP++ notes included in the description of 
the first part of the exercise and in the SCOP++ Manual. 

3. Handling of error messages and program crashes 
Error messages are explained in the SCOP++ manual (section 12.3). 
 
Crash of SCOP++: 
Kill the processes scop++.exe and RPC_TdmServer.exe in the task manager, start 
SCOP++ again (possibly twice). 
Delete all *.TOP and *.TTT files in the directories d:\ScopProjects\topdb\cfg, cvt, 
dpm, grf, mkt, sys. 
Deregister the project (Project ► Deregister ► mark the respective project ►ok) 
and possibly delete the project. 

4. Further Information 
 
SCOP++ Manual 
 
EuroSDR distance learning course: http://www.ipf.tuwien.ac.at/eurosdr/ 
 
Publications: 
 
Kraus K., Pfeifer N., 1998: 
„Determination of terrain models in wooded areas  with airborne laser scanner data“. 
ISPRS Journal, Volume 53, 1998, pp. 193 -  203. 
 
Briese C., Pfeifer N., Dorninger P., 2002:  
"Applications of the Robust Interpolation for DTM determination".  
Presentation: Symposium der ISPRS-Comm. III, Graz; 09-09-2002 - 09-13-2002; in: 
"International Archives of Photogrammetry and Remote Sensing", Volume XXXIV / 
3A (2002), ISSN 1682-1750; 55 - 61. 

http://www.ipf.tuwien.ac.at/eurosdr/�
http://www.ipf.tuwien.ac.at/publications/Briese_Pfeifer_Dorninger.pdf�
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